Deprecating quadrature="trapz" in scipy.integrate.quad_vec

Hi all,

I have opened #20716 to deprecated quadrature="trapz" in integrate.quad_vec as we now have a better name (trapezoid) which is clearer and cannot be interpreted as a slur. In the original issue a number of core devs have already expressed support for but feel free to join in the discussion on the PR!


Thanks, Jake, looks good to me.